Water heater acting weird - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Technical | Towing, Maintenance and Repairs > Heating, Cooling and Appliances
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-29-2020, 12:33 PM   #1
Senior Member
 
Firstime RVer's Avatar
 
Join Date: Jan 2016
Location: allentown
Posts: 234
New Jersey
Water heater acting weird

We discovered this weekend that my Atwood model GC6AA-10E water heater was acting weird.

While on AC power it runs on AC only perfectly.
With no AC power to the TT it runs perfectly on Gas only.
With AC power to the TT it WILL NOT run on GAS only..

When connected to AC I turned the WH gas switch on and heard the familiar light off and gas burning, but our EMS indicated an amp draw equal to when running the WH on electric.
After a few minutes I noticed the gas fault indicator light was lit. So I shut off the gas switch and turned it back on.
Same sequence of events only the second time my relief valve popped!

I suspect I have a stuck relay somewhere.....

Anyone have any ideas?
__________________

__________________
Pat & Barb
2019 5.3L ECOTEC3 V8 Chevy Silverado 1500
2016 Aspen Trail 1900RB
Allentown, NJ
Firstime RVer is offline   Reply With Quote
Old 05-29-2020, 01:34 PM   #2
Senior Member
 
sundancer 87's Avatar
 
Join Date: Dec 2012
Location: Tahlequah
Posts: 2,912
Oklahoma
Did water come out of the TPR valve?
__________________

__________________
2013 Voltage 3800, 2012 Chevy 3500 HD
2010 Yamaha V Star 950
2009 Yamaha Raider
Volunteering with Habitat for Humanity Caravanners
sundancer 87 is offline   Reply With Quote
Old 05-29-2020, 04:01 PM   #3
Senior Member
 
Firstime RVer's Avatar
 
Join Date: Jan 2016
Location: allentown
Posts: 234
New Jersey
It did! Just went POP once, and the a second time about 5 minutes later..
I shut down the gas at that point..
__________________
Pat & Barb
2019 5.3L ECOTEC3 V8 Chevy Silverado 1500
2016 Aspen Trail 1900RB
Allentown, NJ
Firstime RVer is offline   Reply With Quote
Old 05-29-2020, 04:24 PM   #4
Senior Member
 
sundancer 87's Avatar
 
Join Date: Dec 2012
Location: Tahlequah
Posts: 2,912
Oklahoma
Quote:
Originally Posted by Firstime RVer View Post
It did! Just went POP once, and the a second time about 5 minutes later..
I shut down the gas at that point..
It's good the valve did its job. Pressure and or temperature makes them work so since it relieved one or the other or both I'd say the control board or the protection systems failed.
__________________
2013 Voltage 3800, 2012 Chevy 3500 HD
2010 Yamaha V Star 950
2009 Yamaha Raider
Volunteering with Habitat for Humanity Caravanners
sundancer 87 is offline   Reply With Quote
Old 05-29-2020, 07:21 PM   #5
Senior Member
 
Firstime RVer's Avatar
 
Join Date: Jan 2016
Location: allentown
Posts: 234
New Jersey
I couldn't agree more. That 6 gallon tank could have caused a lot of damage if it popped!! I think the temperature controller should have shut down both the gas and electric. I think it shut off the gas but suspect the relay that controls the 110 Volts to the electric heater is stuck.
Took it to a shop. Its worth getting it fixed properly so we can enjoy the rest of the season.
Many thanks for taking the time to reply..
Safe and happy travels.
All the best to you and yours.
Pat
__________________
Pat & Barb
2019 5.3L ECOTEC3 V8 Chevy Silverado 1500
2016 Aspen Trail 1900RB
Allentown, NJ
Firstime RVer is offline   Reply With Quote
Old 06-03-2020, 09:41 PM   #6
Senior Member
 
Join Date: Jul 2014
Location: Dalzell
Posts: 709
South Carolina
I was having the DSI fault. A call to Atwood confirmed my suspicion it was the control board. They told me which one to get (there are many), I ordered on Amazon, and replaced it in literally under 5 minutes. Two screws, two or three wire plugs, that's it. For some, it might be easier to throw $50 or so at the problem, without scheduling and paying for a repair. Yes, it fixed our problem immediately.
__________________

MartyG is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2020 Social Knowledge, LLC All Rights Reserved.
×