Fuel Pump Issues - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Brand RVs > Toy Hauler
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 12-24-2015, 02:36 PM   #1
Senior Member
 
hilbilydavid's Avatar
 
Join Date: Dec 2014
Location: Port Deposit
Posts: 66
Maryland
Fuel Pump Issues

Has any of you had a problem with the fueling station. I went out yesterday to put fuel in my sons 4 wheeler and the pump won't come on, nothing. I use it to fill up his 4 wheeler and just top off the tank with 5 gal cans so I rotate out the fuel, and it's just easier than keeping cans of gas around. I haven't had a chance to check fuses yet, its raining, but when it stops I will. I haven't had a issue until now, we have used it like this for the past 2 years we have had it.
__________________

__________________
2005 Dodge 3500
2014 Voltage V3005
2001 Harley Springer w/120ci motor
hilbilydavid is offline   Reply With Quote
Old 12-24-2015, 06:40 PM   #2
Senior Member
 
arlan in arizona's Avatar
 
Join Date: Nov 2013
Location: Quartzsite
Posts: 682
Arizona
I would check the wiring up behind where the switch is located. Although I haven't had any problems with my fueling station not working. I did clean up and replaced some questionable and loose wire nuts when I first got my trailer.
__________________

__________________
2013 Voltage 3905
2013 F350 4x4 DRW
2013 RZR XP 900
arlan in arizona is offline   Reply With Quote
Old 12-24-2015, 09:05 PM   #3
Senior Member
 
hddecker's Avatar
 
Join Date: Jul 2013
Location: kamloops
Posts: 2,152
British Columbia
Quote:
Originally Posted by arlan in arizona View Post
I would check the wiring up behind where the switch is located. Although I haven't had any problems with my fueling station not working. I did clean up and replaced some questionable and loose wire nuts when I first got my trailer.
You too!
hddecker is offline   Reply With Quote
Old 12-25-2015, 12:18 AM   #4
Senior Member
 
Join Date: Dec 2015
Location: Lakewood
Posts: 89
Colorado
I hope I'm not hijacking this thread.
My new Voltage (used) came with the the pump, hose and handle just laying in the storage compartment. I have no idea how it's wired or even how it mounts. does anyone have pics of how the pump mounts and how it is wired?
Lilnuts is offline   Reply With Quote
Old 12-29-2015, 02:48 PM   #5
New Member
 
Old Coyote's Avatar
 
Join Date: Dec 2015
Location: Mesa
Posts: 3
Arizona
It sounds like the gears in the fuel pump itself. I have had to repair my pump twice by sanding them down so they rotate freely since it was new in 2012. Gasoline makes them expand and they push up too tight against the top of the pump. A slight amount of sanding is all that's necessary. Also remember to use a fuel stabilizer all the time.
Old Coyote is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 09:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×