weird fridge/ electrical question - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen RV Owner's Community Forums > New Member Introductions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 01-25-2015, 07:51 PM   #1
New Member
 
Join Date: May 2014
Location: Port oconnor
Posts: 4
Texas
weird fridge/ electrical question

Hello yall,

Iím new to the forum and the RV life! Well this has me scratching my head and I was hoping someone on here would be able to help. I have a 2008 Dutchmen winner circle toy hauler with a N811 Norcold fridge, well the fridge will run fine with the generator and the propane but when it is just in the AC or (AUTO) mode the green light stays on like it is running fine on AC but the fridge makes a clicking sound from the board in the back and the inside fridge light will not come on. Today I found out that if I turn on any light on the RV the fridge will come on along with the inside fridge light and works fine and if i turn the light off the fridge starts clicking again and will not work.

I have replaced the board in the back with a new one and have a new thermometer in the fridge. Battery is charged and the camper is running on a 50 amp hook up. Also when the furnace is running and you turn the light on you can hear the fan boost up and the air blows harder.
__________________

coastie036 is offline   Reply With Quote
Old 01-26-2015, 01:14 AM   #2
Senior Member
 
Thom's Avatar
 
Join Date: Nov 2014
Location: Youngstown
Posts: 690
Florida
Welcome aboard shipmate!

The combination of two of the three major power draws in your camper having weird symptoms makes me think you have a issue with ground wires in your power circuits. Does your A/C show anything weird? (like blows colder when you flush the toilet...LOL, that was a joke, but does the AC act up?) I would be checking all grounds at batteries and inverters.
__________________

__________________
Thom & Rose
DD-250 ALUMNI
The problem child: 2014 Voltage 3950
The problem solver: 2017 Tiffin Breeze 32BR
Thom is offline   Reply With Quote
Old 01-26-2015, 01:55 AM   #3
New Member
 
Join Date: May 2014
Location: Port oconnor
Posts: 4
Texas
Thank you for the reply. I haven't had a chance to really run the AC lately but this summer it was working just fine. The fridge has been out since July. And iv just been slowly trouble shooting it. And what would I be looking for at the ground just loose or hook up a volt meter?
coastie036 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 01:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2020 Social Knowledge, LLC All Rights Reserved.
×