new to forum Aspen Trail 2780RLS - Dutchmen Owners
Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×

Go Back   Dutchmen Owners > Dutchmen RV Owner's Community Forums > New Member Introductions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-25-2016, 06:52 PM   #1
Member
 
Join Date: Apr 2016
Location: Northeastern
Posts: 11
Pennsylvania
new to forum Aspen Trail 2780RLS

Hello my fellow Dutchmen owners,
Glad to be part of the group and excited to put this new trailer to use. But first the 1 issue I am facing
I have a 2016 Aspen Trail 2780RLS that was brought home a month ago (this is our 2ND trailer, first one was bought used as a learning tool). Thought everything was good to go after the PDI (replaced circuit board for furnace, everything else functioned) however an issue has come up. It appears as though the thermostat (Dometic digital) is not sending a signal to start the furnace. The A/C and fan modes work as they should but when furnace is selected the A/C fan just continues to run. There is no clicking sound to change from fan to furnace.
I will get the model number of the thermostat and furnace tonight but I feel as though after reading through a ton of posts that the issue may be the digital thermostat itself.

Any suggestions would be appreciated as it would be much easier to just fix myself or order a new part (if not major) rather then take the trailer back to the dealer 2 hours away.

Thanks for any insight and happy camping.

Rich
__________________

richtdu89 is offline   Reply With Quote
Old 04-25-2016, 08:05 PM   #2
Senior Member
 
Join Date: Nov 2015
Location: Ft. Pierce
Posts: 312
Florida
Welcome to the forum.

You did have the gas turned on??? If so, the gas line may have some air. Typically, when furnace is selected, the fan should come on for about 15 seconds and then the igniter will attempt to light the gas. If not successful for usually three attempts, it shuts down.
Have someone open the furnace door and listen for the igniter when you select furnace.
If the igniter is working, then you have a gas problem.
If not, you could have a bad thermostat or circuit board. If you didn't check the furnace during the PDI, then you may have a loose wire.
Please report back when you have the problem solved.
__________________

Handyman is offline   Reply With Quote
Old 04-25-2016, 08:30 PM   #3
Senior Member
 
hddecker's Avatar
 
Join Date: Jul 2013
Location: kamloops
Posts: 2,152
British Columbia
Welcome to the forum.

I don't know of you have seen this thread, but it seems to be the answer when this topic comes up.

http://www.dutchmenowners.org/forums...nning-499.html

Your furnace may have gone into lockout mode if it hasn't fired. I can't remember the exact sequence to get it out of lockout mode, but you should be able to find it in you manual.

Good luck in tracking it down.
__________________
Jim

When I was a kid I was going nowhere fast, now I'm an old man I'm going everywhere slow.
hddecker is offline   Reply With Quote
Old 04-25-2016, 09:02 PM   #4
Site Team
 
wahoonc's Avatar
 
Join Date: Jun 2014
Location: Sprung Leak
Posts: 3,156
North Carolina
May need to do a reset on the thermostat. If you post a picture or the make and model number we can probably scare up a manual for you if you don't have one.

Aaron
__________________
There is madness to my methods
2015 Coleman CM16FBS(traded) 2016 Concord 300DS
2015 Ford Fusion Hybrid following along
wahoonc is offline   Reply With Quote
Old 04-26-2016, 11:54 AM   #5
Member
 
Join Date: Apr 2016
Location: Northeastern
Posts: 11
Pennsylvania
I appreciate all of the responses. It was my fault on the PDI, when we were getting started on the furnace something was messed up so they replaced the circuit board while we reviewed other things. Once we got done with everything else my son was getting impatient and I forgot to go back and check.
I am fairly certain it is not a gas problem, yet, as I cant even get the thermostat to change from a/c to engage the furnace. Forgot the model numbers at home but the below link looks to be the same one
Robot Check

The only owners manual we didn't get was the one for the thermostat of course.
Thanks again for the help and responses. Will report back once progress is made

Rich
richtdu89 is offline   Reply With Quote
Old 04-27-2016, 01:04 AM   #6
Site Team
 
wahoonc's Avatar
 
Join Date: Jun 2014
Location: Sprung Leak
Posts: 3,156
North Carolina
Rich,

I think this is the manual that covers your thermostat. This is the one for my Concord, I do have a heat pump, but other than that I think it is basically the same thermostat.

Aaron
__________________
There is madness to my methods
2015 Coleman CM16FBS(traded) 2016 Concord 300DS
2015 Ford Fusion Hybrid following along
wahoonc is offline   Reply With Quote
Old 04-27-2016, 11:56 AM   #7
Member
 
Join Date: Apr 2016
Location: Northeastern
Posts: 11
Pennsylvania
Thank you Aaron, this appears to have what I need to at least get to the next step.
I should add that this is an awesome trailer, they all have their quirks at some point but I think Dutchmen did a really nice job with the design, layout, and finish. Cant wait to hit the road in a few weeks.

Thanks again for the help and I will report back with results.

Rich
richtdu89 is offline   Reply With Quote
Old 04-28-2016, 12:12 PM   #8
Member
 
Join Date: Apr 2016
Location: Northeastern
Posts: 11
Pennsylvania
Thanks everyone for all of the help. After all of the frustration the problem was the switch on the furnace itself, backward labeling. All is good and we are up and running.

Rich
richtdu89 is offline   Reply With Quote
Old 04-28-2016, 02:26 PM   #9
Senior Member
 
hddecker's Avatar
 
Join Date: Jul 2013
Location: kamloops
Posts: 2,152
British Columbia
Wouldn't that frost your backside.
__________________

__________________
Jim

When I was a kid I was going nowhere fast, now I'm an old man I'm going everywhere slow.
hddecker is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 04:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Copyright 2020 Social Knowledge, LLC All Rights Reserved.
×