Generator stops after 2 minutes of running - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen RV Owner's Community Forums > Forum Help | Announcements | Member Concerns
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-30-2018, 04:04 AM   #1
Member
 
Join Date: Aug 2015
Location: Peoria
Posts: 10
Arizona
Generator stops after 2 minutes of running

Voltage 3970, Onan 5500 gen. Unit was sitting for 2 months since last time gen was used. Started gen, ran for 2 minutes the stopped. Waited for couple of minutes then started again. Stopped after 2 minutes. Changed spark plugs, fuel filter (3 times), new fuel pump, oil change. Even fed the fuel straight from a gas can. No changes. The only thing I have left is the carburetor.
I am not sure the carb is the issue. Seems to run just fine for the couple of minutes.
Any ideas? Maybe something to do with the generator taking on a load and having an issue? Trying to get answers before taking to the shop.
__________________

rsstangl is offline   Reply With Quote
Old 10-31-2018, 12:43 AM   #2
Member
 
Join Date: Aug 2015
Location: Peoria
Posts: 10
Arizona
Generator stops after 2 minutes of running

Re-posted this to this thread hoping to get some response.
Voltage 3970, Onan 5500 gen. Unit was sitting for 2 months since last time gen was used. Started gen, ran for 2 minutes the stopped. Waited for couple of minutes then started again. Stopped after 2 minutes. Changed spark plugs, fuel filter (3 times), new fuel pump, oil change. Even fed the fuel straight from a gas can. No changes. The only thing I have left is the carburetor.
I am not sure the carb is the issue. Seems to run just fine for the couple of minutes.
Any ideas? Maybe something to do with the generator taking on a load and having an issue? Trying to get answers before taking to the shop.
__________________

rsstangl is offline   Reply With Quote
Old 10-31-2018, 01:35 AM   #3
Senior Member
 
Join Date: Jun 2017
Location: tampa
Posts: 1,157
Florida
Quote:
Originally Posted by rsstangl View Post
Re-posted this to this thread hoping to get some response.
Voltage 3970, Onan 5500 gen. Unit was sitting for 2 months since last time gen was used. Started gen, ran for 2 minutes the stopped. Waited for couple of minutes then started again. Stopped after 2 minutes. Changed spark plugs, fuel filter (3 times), new fuel pump, oil change. Even fed the fuel straight from a gas can. No changes. The only thing I have left is the carburetor.
I am not sure the carb is the issue. Seems to run just fine for the couple of minutes.
Any ideas? Maybe something to do with the generator taking on a load and having an issue? Trying to get answers before taking to the shop.
I would check the carb. Runs until it runs out of fuel. Probably a stuck needle valve Bowl fills up too slowly to keep running but fuel seeps into carb to fill bowl..look there!
franktafl is offline   Reply With Quote
Old 10-31-2018, 02:10 AM   #4
Senior Member
 
Join Date: Jul 2013
Location: Houma
Posts: 239
Louisiana
I had a very similar issue.

After the generator shuts down, is the Start/Stop switch light flashing? If so, press down (Stop) and take note of the flashing lights. It will flash a set number of times, pause, and flash a different set. (3 blinks, pause, 6 blinks = Fault code 36)

In my case, a chip on the controller board had blown. Surprisingly the generator still started up and ran, but would shut down after a few minutes.

Let us know what you find and I can try to help you remove the control board to check it out.
__________________
2013 Voltage Epic 3600
2006 GMC Sierra 2500HD Diesel (LBZ)
Sinecure is offline   Reply With Quote
Old 10-31-2018, 03:41 AM   #5
Senior Member
 
Join Date: Jan 2018
Location: Beaver Dam
Posts: 130
Wisconsin
My portable Honda would run about an hour before stopping. It should run about 5 hours with a significant load.
The carb had red sediment in the float bowel. Cleaned carb, lines, and filter. Now it runs until there in no fuel left.
I now use fuel stabilizer in the gas. I was told long periods of not being used would cause problems. Now I believe.
persistent is offline   Reply With Quote
Old 10-31-2018, 11:17 AM   #6
Senior Member
 
Thom's Avatar
 
Join Date: Nov 2014
Location: Youngstown
Posts: 563
Florida
Sure sounds like your float/needle valve in your carb to me.
Thom is offline   Reply With Quote
Old 11-02-2018, 03:10 AM   #7
Member
 
Join Date: Aug 2015
Location: Peoria
Posts: 10
Arizona
Thanks for the replies. I thought about the carburetor, just have not gotten into that yet. I will check on the carb this weekend. Yes, the light on the switch is blinking when it shuts down. The fault code is 36. Where is the control board located? The trailer is in storage not close to the house so I have to go on the weekends. I will look at the owners manual also to try to find the location.
rsstangl is offline   Reply With Quote
Old 11-02-2018, 08:24 AM   #8
Senior Member
 
donzinger's Avatar
 
Join Date: Aug 2013
Location: Memphis
Posts: 1,355
Michigan
I believe the control board is under the cover the switch is mounted to.
__________________
2014-3950, Full Paint, 17.5" tires, 370W solar, 3100W Magnum inverter w/ AGS, 7500w diesel generator, Micro-Air Easy Start 364 (x3)
2005 Ram 3500 CTD, ATS Aurora 3000, air bags, train horns, Banks hardware, Smarty Jr software, 105 gal aux tank
donzinger is offline   Reply With Quote
Old 11-02-2018, 06:20 PM   #9
Senior Member
 
Join Date: Oct 2017
Location: Aiken
Posts: 255
South Carolina
Quote:
Originally Posted by rsstangl View Post
Voltage 3970, Onan 5500 gen. Unit was sitting for 2 months since last time gen was used. Started gen, ran for 2 minutes the stopped. Waited for couple of minutes then started again. Stopped after 2 minutes. Changed spark plugs, fuel filter (3 times), new fuel pump, oil change. Even fed the fuel straight from a gas can. No changes. The only thing I have left is the carburetor.
I am not sure the carb is the issue. Seems to run just fine for the couple of minutes.
Any ideas? Maybe something to do with the generator taking on a load and having an issue? Trying to get answers before taking to the shop.

Never tried this with an ONAN, but. With a few other type of small motors.

When I have suspected dirty old gasoline/carburetor issues, I put in a LOT of Stabilt in the tank and run. Let sit. Run again. etc.

I guess in addition to preserving gas it has some "cleaning/unclogging properties. You might get lucky


Good luck.
Bill
ArmyVeteran is offline   Reply With Quote
Old 11-02-2018, 06:55 PM   #10
Senior Member
 
Join Date: Jun 2017
Location: tampa
Posts: 1,157
Florida
Quote:
Originally Posted by rsstangl View Post
Thanks for the replies. I thought about the carburetor, just have not gotten into that yet. I will check on the carb this weekend. Yes, the light on the switch is blinking when it shuts down. The fault code is 36. Where is the control board located? The trailer is in storage not close to the house so I have to go on the weekends. I will look at the owners manual also to try to find the location.
Code 36 means the engine stopped without a shutdown command from the control panel. This could be caused by a bad fuel pump, clogged filter, crimped fuel line, dirty carb, and on and on.
__________________

franktafl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.



All times are GMT. The time now is 03:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.