Radio/DVD problem - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Technical | Towing, Maintenance and Repairs > Interior and Living
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-26-2015, 04:06 PM   #1
Senior Member
 
GTWags's Avatar
 
Join Date: Sep 2015
Location: Oklahoma City
Posts: 101
Oklahoma
Radio/DVD problem

No video to TV, how do I get to the back of the DVD unit?
__________________

GTWags is offline   Reply With Quote
Old 09-26-2015, 05:37 PM   #2
Senior Member
 
ATCguy's Avatar
 
Join Date: May 2013
Location: Somewhere on the road...
Posts: 1,305
Wyoming
Which DVD unit? What rig? What room?

We don't all own the same make & model RV, and you're not giving us much to go on...
__________________

__________________
Tom
2013 VOLTAGE 3200 (EPIC I & II)
2014 Ford F-450 PLATINUM
2017 BMW R1200GS Rallye
ATCguy is offline   Reply With Quote
Old 09-26-2015, 07:34 PM   #3
Site Team
 
wahoonc's Avatar
 
Join Date: Jun 2014
Location: Sprung Leak
Posts: 3,138
North Carolina
Sawzall and a big hammer is one option...

Aaron
__________________
There is madness to my methods
2015 Coleman CM16FBS(traded) 2016 Concord 300DS
2015 Ford Fusion Hybrid following along
wahoonc is offline   Reply With Quote
Old 09-26-2015, 07:55 PM   #4
Senior Member
 
GTWags's Avatar
 
Join Date: Sep 2015
Location: Oklahoma City
Posts: 101
Oklahoma
Since when does this not show a signature? 2016 aerolite 213rbsl. There's only one room, unless they started putting dvd players in the bathroom. First time I tried to use the DVD portion of the Furrion system and it has sound and recognizes the DVD, just no video to TV. Figured a video cable not hooked up. Looks like I might have to use a sledge to get in to the back of it.
__________________
2016 Aerolite 213RBSL
2013 F-150 5.0l tow package
GTWags is offline   Reply With Quote
Old 09-26-2015, 08:07 PM   #5
Site Team
 
wahoonc's Avatar
 
Join Date: Jun 2014
Location: Sprung Leak
Posts: 3,138
North Carolina
Quote:
Originally Posted by GTWags View Post
Since when does this not show a signature? 2016 aerolite 213rbsl. There's only one room, unless they started putting dvd players in the bathroom. First time I tried to use the DVD portion of the Furrion system and it has sound and recognizes the DVD, just no video to TV. Figured a video cable not hooked up. Looks like I might have to use a sledge to get in to the back of it.
No signature on the first post. I do agree that is sounds like a video cable was not hooked up. Any idea which specific Furion model it is? From the one manual I looked at, it appears the lower cover pops off and there are mounting screws behind that. Once those are out you can pull the unit out of the wall and check for the cables. Furion has manuals on their website if you know which one you have.

Aaron
__________________
There is madness to my methods
2015 Coleman CM16FBS(traded) 2016 Concord 300DS
2015 Ford Fusion Hybrid following along
wahoonc is offline   Reply With Quote
Old 09-26-2015, 08:41 PM   #6
Senior Member
 
ATCguy's Avatar
 
Join Date: May 2013
Location: Somewhere on the road...
Posts: 1,305
Wyoming
Quote:
Originally Posted by wahoonc View Post
No signature on the first post:
Yep, definitely nothing there on the initial post... weird that it shows up on the 2nd, but still doesn't on the first. Guess the web board had a hiccup....

__________________
Tom
2013 VOLTAGE 3200 (EPIC I & II)
2014 Ford F-450 PLATINUM
2017 BMW R1200GS Rallye
ATCguy is offline   Reply With Quote
Old 09-26-2015, 09:58 PM   #7
Senior Member
 
Join Date: May 2015
Location: Oxnard
Posts: 187
California
I've got an HDMI cable from the DVD to the main TV for both audio and video
__________________
2015 Voltage 3800 w/ Epic, Int&Ext, Garage Pkgs; 4x100W Solar, Xantrex C35 Charge, SW2000 Inverter & Mon; 2005 Chevy Duramax Dually 3500 w/Banks; Kawi KFX700 & Polaris Scrambler 500 ATVs.
VCToyhauler is offline   Reply With Quote
Old 09-26-2015, 10:10 PM   #8
Senior Member
 
GTWags's Avatar
 
Join Date: Sep 2015
Location: Oklahoma City
Posts: 101
Oklahoma
Yup, bottom cover. Video and audio wire were reversed. Simple but maddening fix.
__________________
2016 Aerolite 213RBSL
2013 F-150 5.0l tow package
GTWags is offline   Reply With Quote
Old 12-04-2015, 10:36 AM   #9
Senior Member
 
Join Date: Jun 2012
Location: Eldersburg
Posts: 291
Maryland
During our last trip, our Furrion DV1000 system started having trouble. The radio would automatically go into scan mode every 5 minutes or so. Additionally the DVD player suddenly stopped working.

I contacted Furrion since it is under the 1-year. They asked for information on the unit (Serial Number, Model, date of purchase, etc) and said they will ship me a replacement unit with a Return postage-paid. Will be pulling the unit this weekend so that I can get the SN#.

It's nice when a vendor will work with you!
__________________
Matt

2011 Chevy Suburban 2500 4x4
2015 Kodiak 300BHLS
mjcarte is offline   Reply With Quote
Old 12-04-2015, 04:58 PM   #10
Senior Member
 
Join Date: Aug 2015
Location: Meridian
Posts: 54
Idaho
Quote:
Originally Posted by mjcarte View Post
During our last trip, our Furrion DV1000 system started having trouble. The radio would automatically go into scan mode every 5 minutes or so. Additionally the DVD player suddenly stopped working.

I contacted Furrion since it is under the 1-year. They asked for information on the unit (Serial Number, Model, date of purchase, etc) and said they will ship me a replacement unit with a Return postage-paid. Will be pulling the unit this weekend so that I can get the SN#.

It's nice when a vendor will work with you!
My Furrion won't sync with my new Ipod on bluetooth. Their answer: "It doesn't work with all devices". Seriously, it's an iPod for God sake. So I ended up purchasing a blue tooth speaker "Monster" for cheap off Amazon and it works great.

Haven't used the cables, but with the other issues I've had, I wouldn't be surprised if the factory connected them incorrectly.
RickNTee is offline   Reply With Quote
Old 12-21-2015, 10:28 AM   #11
Senior Member
 
Join Date: Jun 2012
Location: Eldersburg
Posts: 291
Maryland
To my surprise, we received the replacement on Saturday. I went out on Sunday with generator in tow. Connected the replacement DV1100 (sorry original post said it was a DV1000) and the radio worked without scanning every 5 minutes. Connected to the TV and put a DVD in the unit, and everything appears to be working again. I am sending the defective unit back to them, postage prepaid.

It's great when the vendor helps you out.
__________________

__________________
Matt

2011 Chevy Suburban 2500 4x4
2015 Kodiak 300BHLS
mjcarte is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 07:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×