Domestic ac not working - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Technical | Towing, Maintenance and Repairs > Heating, Cooling and Appliances
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 07-08-2015, 01:31 PM   #1
Member
 
Join Date: Sep 2014
Location: Savannah
Posts: 18
Georgia
Domestic ac not working

dometic b59516 ac does not turn on. From the single zone thermostat when turned to cool there is a click from the ac unit but does not turn on, same with fan.
__________________

Middlesb4 is offline   Reply With Quote
Old 07-08-2015, 04:38 PM   #2
Senior Member
 
Join Date: Dec 2011
Location: Helena, MT
Posts: 461
Montana
Is this your first time trying to run the AC?
Are you plugged in to shore power (120V AC)?
Can you confirm 120V AC power is live in the camper?
Can you confirm that the 120V AC breaker for the air con is in the "on" position?
__________________

__________________
2012 Aspen Trail 2710BH | 280 watts of solar on the roof | 2x6V GC batteries | 100% LED lighting | 1500 & 300 watt PSW inverters | so far strictly boondocking
ewarnerusa is offline   Reply With Quote
Old 07-08-2015, 09:32 PM   #3
Member
 
Join Date: Sep 2014
Location: Savannah
Posts: 18
Georgia
I Am on shore power and it is day 3 of a 12 day stay, last night the ac and fan stopped working. All breakers are in the on position.
Middlesb4 is offline   Reply With Quote
Old 07-09-2015, 08:41 PM   #4
Senior Member
 
Join Date: Dec 2011
Location: Helena, MT
Posts: 461
Montana
Do other 120V AC items work off of the shore power? I was just thinking that your symptoms sound like there is no 120V AC being provided. Sounds too simple to be the culprit, but worth verifying!
__________________
2012 Aspen Trail 2710BH | 280 watts of solar on the roof | 2x6V GC batteries | 100% LED lighting | 1500 & 300 watt PSW inverters | so far strictly boondocking
ewarnerusa is offline   Reply With Quote
Old 07-09-2015, 09:15 PM   #5
Site Team
 
wahoonc's Avatar
 
Join Date: Jun 2014
Location: Sprung Leak
Posts: 3,138
North Carolina
Quote:
Originally Posted by Middlesb4 View Post
I Am on shore power and it is day 3 of a 12 day stay, last night the ac and fan stopped working. All breakers are in the on position.
Did you physically turn the breakers off then back on? Sounds simple but sometimes one will partially trip and look like it is on. Could be a loose connection on the back of the breaker, or even a bad breaker.

Aaron
__________________
There is madness to my methods
2015 Coleman CM16FBS(traded) 2016 Concord 300DS
2015 Ford Fusion Hybrid following along
wahoonc is offline   Reply With Quote
Old 07-09-2015, 10:29 PM   #6
Member
 
Join Date: Sep 2014
Location: Savannah
Posts: 18
Georgia
Turned out to be something simple, I first download the domestic service manual and conducted continuity checks of everything and still nothing, so I decided to open up the box that the troubleshooting guides did not mention,nor trouble shoot, there was a disconnected wire set that came apart, 3 hours later a 2 minute fix solved the ac problem
Middlesb4 is offline   Reply With Quote
Old 07-09-2015, 10:32 PM   #7
Senior Member
 
Thom's Avatar
 
Join Date: Nov 2014
Location: Youngstown
Posts: 646
Florida
__________________

__________________
Thom & Rose
DD-250 ALUMNI
The problem child: 2014 Voltage 3950
The problem solver: 2017 Tiffin Breeze 32BR
Thom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×