Convection Oven Issues? - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Technical | Towing, Maintenance and Repairs > Heating, Cooling and Appliances
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-08-2013, 01:13 AM   #1
Senior Member
 
Join Date: Nov 2012
Location: Goshen
Posts: 363
Indiana
Convection Oven Issues?

Talking to several different people through RV forums (this one and others). Dutchmen, Heartland, and Redwood all Thor products, are having issues with the convection ovens.

Is anyone out there having the same. If so, would you chime in and let everyone know in this forum.
__________________

__________________
Dave

2012 Dutchmen 3850RL
Infinityrver is offline   Reply With Quote
Old 04-08-2013, 01:56 AM   #2
Senior Member
 
72mach's Avatar
 
Join Date: Feb 2013
Location: Albuqueque
Posts: 165
New Mexico
Our Dometic had the F5 error the first two days we setup the trailer. First day it didn't go away until the next morning and the second day it was a couple of hours. The third day when we arrived at the permanent spot it had no issues when we hooked up power. Its been three weeks and no further problems. There are several threads about this error and I was expecting it to be replaced but so far so good.
__________________

__________________
2009 F350 CC 4x4 SRW 6.4
2012 Infinity 3750FL
-Countless issues with the trailer=junk.
72mach is offline   Reply With Quote
Old 04-09-2013, 01:52 AM   #3
Senior Member
 
Tanman's Avatar
 
Join Date: Jul 2012
Posts: 521
No issues with ours yet. The only thing i can say bad about it is the unit doesn't seem to be a 1000 watt or higher. It takes a lot longer than home to heat food.
Tanman is offline   Reply With Quote
Old 08-21-2013, 06:06 PM   #4
New Member
 
Join Date: Aug 2013
Location: Land O Lakes
Posts: 2
Florida
We had the same error code on our 2012 Voltage 3200, and found it to occur only when connected to 30 amp power, and when we used the a/c, coffee pot, toaster, micro at the same time. It seems to be a drop in voltage/amperage that causes that code.

We had ours documented for future reference, but (knock on wood), we have not had a single reoccurrence since we avoid excessive power use when hooked to 30 amp power.
griffsresort is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 08:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×