1996 duck electrical issues when attached to vehicle - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Technical | Towing, Maintenance and Repairs > Electrical, Batteries, Charging and Electronics
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-01-2015, 05:04 AM   #1
New Member
 
Join Date: Aug 2015
Location: Fort Saskatchewan
Posts: 1
Alberta
1996 duck electrical issues when attached to vehicle

We picked up a used 1006 Duck this weekend and rewired the trailer hitch to be able to hook up to our seven blade hitch directly. We replaced the ground wires, and now we have problems.

Our flashers, brake lights, and running lights on the trailer all work properly when the wires are connected to the battery on the trailer.

Our seven blade hitch tests as having power running through it properly.

When we plug in the trailer end into the hitch we have nothing working.

Anyone have a technical manual they have found helpful or can lead me to a thread that has addressed this previously?
shaunao is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 01:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×