Issue with Jensen AWM965 unit... - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Brand RVs > General RV Related Discussions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-04-2018, 12:34 AM   #1
Member
 
Join Date: Mar 2018
Location: ABERDEEN
Posts: 39
North Carolina
Issue with Jensen AWM965 unit...

We bought our TT used about 3 months ago and I decided to try the outside speakers (Jensen) to see what they sounded like. They did not work. After looking at them, I noticed that both tweeters were disconnected from the speaker so I bought replacement 5.25" speakers (Polk DB522). I installed them today and noted that I still was not gettin hardly any sound from them. The inside speakers work fine but when I push the button for the outside speakers, I get crap. Is there a problem with the head unit or do the outside speakers need a separate amp?

Also, a second issue that I am having is that when I play a movie, the sound only comes out of the inside speakers, I can not have the audio sent to my TV and only use the TV speaker. I have the 3 RCA cables plugged into the back of the TV with audio going into the TV but I can not use the TV speaker with a movie.
__________________

__________________
Retired USAF 1974 - 1994 MSgt
2014 Coleman Expedition CTS-192R
2019 RAM 1500 5.7 Big Horn 4X4 off road package
2001 Chevy Silverado Z71 5.3l extended cab
stepbill is offline   Reply With Quote
Old 06-04-2018, 02:01 AM   #2
Site Team
 
wahoonc's Avatar
 
Join Date: Jun 2014
Location: Sprung Leak
Posts: 3,139
North Carolina
Not sure about all the issues, however based on what I have seen, they seldom wire anything correctly. Here is a link to the manual. According to the manual you have a 20 pin connector, I strongly suspect something is not wired correctly and/or has a bad connection.

Aaron
__________________

__________________
There is madness to my methods
2015 Coleman CM16FBS(traded) 2016 Concord 300DS
2015 Ford Fusion Hybrid following along
wahoonc is offline   Reply With Quote
Old 06-04-2018, 09:28 PM   #3
Member
 
Join Date: Mar 2018
Location: ABERDEEN
Posts: 39
North Carolina
Wish that I would have thought to check the balance and fader settings first for those speakers !
__________________
Retired USAF 1974 - 1994 MSgt
2014 Coleman Expedition CTS-192R
2019 RAM 1500 5.7 Big Horn 4X4 off road package
2001 Chevy Silverado Z71 5.3l extended cab
stepbill is offline   Reply With Quote
Old 06-05-2018, 01:10 AM   #4
Senior Member
 
Thom's Avatar
 
Join Date: Nov 2014
Location: Youngstown
Posts: 651
Florida
Glad we could help!


But thanks for letting us know how you fixed it, often we never hear back as to what fixed it.
Thom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 07:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×