Water pump gives out in a week - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Brand RVs > Toy Hauler
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-31-2014, 01:53 AM   #1
Senior Member
 
Camper2b's Avatar
 
Join Date: Feb 2014
Location: Nashville
Posts: 538
Tennessee
Water pump gives out in a week

My water pump made it a week. Really is a piece of junk. Doesn't look to bad to change out. Guess I'll go with a shureflow.... and you say???

Thanks
__________________

__________________
Slim
Former 2014 Vlotage 3200 owner
Camper2b is offline   Reply With Quote
Old 03-31-2014, 04:10 AM   #2
Senior Member
 
Wanderer's Avatar
 
Join Date: May 2012
Location: Nanaimo
Posts: 484
British Columbia
Get it changed under warranty, replace it with the Shurflo and sell the warranty replacement unit to offset the cost.
It really is an easy swap out.
What brand is the faulty one? Maybe you just got a lemon.
__________________

__________________
Gordon and Laura Howe
Vancouver Island, British Columbia
2010 Komfort Resort 240RK
Wanderer is offline   Reply With Quote
Old 03-31-2014, 12:31 PM   #3
Senior Member
 
sundancer 87's Avatar
 
Join Date: Dec 2012
Location: Tahlequah
Posts: 2,824
Oklahoma
Even the cheapest water pumps last longer than a week. Maybe you don't need to drag to the dealership for diagnosis if it's something as simple as a loose wire nut.
__________________
2013 Voltage 3800, 2012 Chevy 3500 HD
2010 Yamaha V Star 950
2009 Yamaha Raider
Volunteering with Habitat for Humanity Caravanners
sundancer 87 is offline   Reply With Quote
Old 03-31-2014, 12:57 PM   #4
Senior Member
 
Camper2b's Avatar
 
Join Date: Feb 2014
Location: Nashville
Posts: 538
Tennessee
Not sure of the brand until I get in there. Yes warranty will cover and I'm sure dealership will get me a new pump and I'll save it for a spare. As for the pump that apperars to be history, it still runs but is making a loud knocking noise and continues to loose prime. Water tanks full all the simple stuff checked.

A visual inspection through vent hole doesn't show any water leaks around it on either intake or supply side. I think its just a cheap pump. When I turned it on... it vibrates violently shaking all the water lines and sounds like a car motor fixing to throw a rod.
__________________
Slim
Former 2014 Vlotage 3200 owner
Camper2b is offline   Reply With Quote
Old 03-31-2014, 04:21 PM   #5
Senior Member
 
arlan in arizona's Avatar
 
Join Date: Nov 2013
Location: Quartzsite
Posts: 682
Arizona
Just a suggestion here.

Mine did that once after I had drained the tanks. I got air in the lines and and it took quite awhile to get it purged. If you are home (not boon docking) turn on all the faucets, including running a hose from your washing machine hookup and hold you toilet valve open. It took awhile but I got mine to go silent again and it was making really loud knocking sounds.

Also, hooking up to your city water connection and running that might help.
__________________
2013 Voltage 3905
2013 F350 4x4 DRW
2013 RZR XP 900
arlan in arizona is offline   Reply With Quote
Old 04-01-2014, 12:49 AM   #6
Senior Member
 
Camper2b's Avatar
 
Join Date: Feb 2014
Location: Nashville
Posts: 538
Tennessee
Thanks Arlan, I tried all that this morning. It would run smooth and loose prime without notice. I've used it the entire week, actually 8 days. I went ahead and replaced it with a new shurflow. The shurflow runs smoothly and cant even hear it. Although the specs are about the same I noticed an increase in water pressure. All is good. While in there I straightened out a few areas..."behind the wall".. oh my! Where is the pride in workmanship anymore.
__________________
Slim
Former 2014 Vlotage 3200 owner
Camper2b is offline   Reply With Quote
Old 04-01-2014, 01:14 AM   #7
Senior Member
 
arlan in arizona's Avatar
 
Join Date: Nov 2013
Location: Quartzsite
Posts: 682
Arizona
Glad to hear you got it fixed. I just put a spare pump in my trailer. Just in case.
__________________
2013 Voltage 3905
2013 F350 4x4 DRW
2013 RZR XP 900
arlan in arizona is offline   Reply With Quote
Old 04-01-2014, 04:04 AM   #8
Senior Member
 
Join Date: Feb 2014
Location: Tucson
Posts: 731
Arizona
What brand was the pump that failed?
__________________
2014 Voltage 3600
2013 Chevy 3500 CC DRW
2011 Harley Ultra Limited
azdryheat is offline   Reply With Quote
Old 04-01-2014, 12:55 PM   #9
Senior Member
 
Camper2b's Avatar
 
Join Date: Feb 2014
Location: Nashville
Posts: 538
Tennessee
Its a WFCO company. Home just click on the home link, its shown on their site.
__________________
Slim
Former 2014 Vlotage 3200 owner
Camper2b is offline   Reply With Quote
Old 04-02-2014, 05:22 AM   #10
New Member
 
Join Date: Apr 2014
Location: Osoyoos
Posts: 4
British Columbia
I had the same problem. Brand new trailer. First week. But mine started leaking, and was replaced no questions asked. I do find they are a noisy pump. How much did a shureflo cost you?
__________________

elliotthesparky is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.



All times are GMT. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.