schwintek slide out mechanism. - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Brand RVs > Fifth Wheel
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 01-29-2015, 04:33 AM   #1
New Member
 
Join Date: Jan 2015
Location: LOS MOLINOS
Posts: 1
California
Unhappy schwintek slide out mechanism.

2014 293 rks with galley slide problems, anyone had this problem top of slide is flat against seal bottom sticks out 1 and a half inches. Been in shop for 3 and a half months.
__________________

Jerry d is offline   Reply With Quote
Old 01-29-2015, 01:02 PM   #2
Senior Member
 
Camper2b's Avatar
 
Join Date: Feb 2014
Location: Nashville
Posts: 538
Tennessee
Schwintek slide problem

Jerry - sorry to hear about your slide. Just type in schwintek slide issues in search box and you'll find several stories similar to yours and possible causes and fixes. The link above is one of many on this site. Google same on web for others. Good luck.
__________________

__________________
Slim
Former 2014 Vlotage 3200 owner
Camper2b is offline   Reply With Quote
Old 01-29-2015, 05:03 PM   #3
Senior Member
 
Join Date: Feb 2014
Location: Tucson
Posts: 647
Arizona
It took five months for my dealer to get the parts to fix my Schwintek slide. What I did was let them look at it to determine the problem and then I brought it home. When the parts finally came in they kept it for 3 days for the fix. Now the slide works great but there is no way my trailer is going to sit at the dealer for months on end. I've also vowed to never again buy anything with a Schwintek slide system.
__________________
2014 Voltage 3600
2013 Chevy 3500 CC DRW
2011 Harley Ultra Limited
azdryheat is offline   Reply With Quote
Old 01-29-2015, 06:03 PM   #4
Senior Member
 
Join Date: Nov 2013
Location: Fredericksburg
Posts: 213
Virginia
I know most do not like the Schwintek slides but in reality it is simple system. One motor that operates each side, one shaft that turns top and bottom simultaneously. Not saying its the right thing to use or the slides are not too heavy for this set up, just that it is a simple system.

I am wondering if you removed the one screw that secures the motor, lift the motor and turn a quarter turn (as you would to manually push the slide in). Try pushing the bottom in manually and then resetting the motor. Just a thought, because it just sounds like the track's are out alignment.

My bedroom slide was out of alignment side to side and it was an easy fix. Pulled the slide out 10" or so, then back in all the way, did this 3 or 4 times and it was good to go.
__________________

Phil
2014 Voltage 3950 Epic III
2016 Ram 3500 Diesel 4wd, Long Horn Dually long bed
Moto4play is offline   Reply With Quote
Old 01-29-2015, 06:45 PM   #5
Senior Member
 
donzinger's Avatar
 
Join Date: Aug 2013
Location: Memphis
Posts: 1,354
Michigan
My warranty repair service technician actually told me that I should always run the slide all the way in or out (depending on setting up or tearing down), go back the other direction a few inches and then all the way each time to ensure proper alignment at all times. Not sure if it is true but sort of makes sense so we do - no issues yet with the slides at all.
__________________
2014-3950, Full Paint, 17.5" tires, 370W solar, 3100W Magnum inverter w/ AGS, 7500w diesel generator, Micro-Air Easy Start 364 (x3)
2005 Ram 3500 CTD, ATS Aurora 3000, air bags, train horns, Banks hardware, Smarty Jr software, 105 gal aux tank
donzinger is offline   Reply With Quote
Old 01-29-2015, 07:01 PM   #6
Senior Member
 
Join Date: Nov 2013
Location: Fredericksburg
Posts: 213
Virginia
Correction: I did slide the unit all the way out and then in about 8-10" 3 times. Here is the link to the video where I found it.
__________________

Phil
2014 Voltage 3950 Epic III
2016 Ram 3500 Diesel 4wd, Long Horn Dually long bed
Moto4play is offline   Reply With Quote
Old 02-01-2015, 12:59 PM   #7
New Member
 
Join Date: Jul 2013
Location: just south of Denver
Posts: 8
Colorado
Good video & info--haven't had any issues on my rig with the slides but nice to have an idea of how to keep it all synched up...
__________________
2011 Ford F250 6.7
2009 Jeep Wrangler Sahara
2013 Infinity 3860MS
txdutt0122 is offline   Reply With Quote
Old 02-02-2015, 03:04 PM   #8
Senior Member
 
DesertRat's Avatar
 
Join Date: Mar 2014
Location: Desert Hot Springs
Posts: 1,760
California
Thanks for the Video Very good info that I didn't know about. I also haven't had any problems with mine but this is good info that all should know about.
__________________

__________________
Mike
2002 42' Monaco Signature Triple Crown tow 2014 F-150
2014 Voltage V3605 Sold 5/3/17
2012 F-350 6.7l CC 4X4, Sold 10/10/17
DesertRat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.



All times are GMT. The time now is 06:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.