1993 Dutchmen Classic blowing 15a fuse - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Brand RVs > Fifth Wheel
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 04-23-2017, 03:54 PM   #1
New Member
 
Join Date: Apr 2017
Location: East
Posts: 4
Tennessee
1993 Dutchmen Classic blowing 15a fuse

Hi. I have a 1993 Dutchmen Classic 5th Wheel. I bought a new battery for it. All lights, furnace, fridge, seemed to work ok. The next day, the battery was dead. I think the gas sniffer drained the battery. The sniffer wires were unhooked from the battery when I got the camper, but I hooked them up when installing new battery.

I noticed the last accessory fuse (15amp) was blown. ( last fuse on right in picture below red wire) I replaced it and it immediately blew again. Is this fuse for battery charging system or power converter, or appliance? I don't think my battery is charging when hooked to my truck.

Also, should there be a ground cable connected from the negative battery terminal to the trailers metal frame? Mine doesn't have one. Thanks in advance for your advise and guidance.
CooP
Attached Thumbnails
Click image for larger version

Name:	IMG_5640.jpg
Views:	76
Size:	59.2 KB
ID:	4023  
CooP is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.


All times are GMT. The time now is 04:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.
×