Stabilizer jacks and slide not getting power Aspen Trail 2860RLS - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen Brand RVs > Travel Trailer
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 10-23-2018, 07:32 PM   #1
New Member
 
Join Date: Oct 2018
Location: Houston
Posts: 2
Texas
Stabilizer jacks and slide not getting power Aspen Trail 2860RLS

My slide and my stabilizer jacks are not getting power. Never had this type of trailer before and I am set up but need to move my RV in a month. Any help would be appreciated. Fuses not blown, all wiring seems tight. What am I missing?
__________________

Austinagain is offline   Reply With Quote
Old 10-23-2018, 09:39 PM   #2
Senior Member
 
Join Date: Jun 2017
Location: tampa
Posts: 1,811
Florida
Quote:
Originally Posted by Austinagain View Post
My slide and my stabilizer jacks are not getting power. Never had this type of trailer before and I am set up but need to move my RV in a month. Any help would be appreciated. Fuses not blown, all wiring seems tight. What am I missing?
a ground
__________________

franktafl is offline   Reply With Quote
Old 10-24-2018, 01:23 AM   #3
New Member
 
Join Date: Oct 2018
Location: Houston
Posts: 2
Texas
Slide and stabilizer jacks not working.

I checked the wiring and the grounds. Removed everything, cleaned the connections and still nothing. Anything else?
Austinagain is offline   Reply With Quote
Old 10-24-2018, 10:29 AM   #4
Senior Member
 
Join Date: Jun 2017
Location: tampa
Posts: 1,811
Florida
Quote:
Originally Posted by Austinagain View Post
I checked the wiring and the grounds. Removed everything, cleaned the connections and still nothing. Anything else?
are you attached to shore power or just attempting to use battery power? Do you have power to the switches?
franktafl is offline   Reply With Quote
Old 10-24-2018, 10:52 AM   #5
Senior Member
 
Join Date: Jan 2015
Location: Roselle
Posts: 1,139
Illinois
Just had similar problem (different unit). Technician found it was a bad relay/fuse. Jumped it and I was good to go. I'm not an electrical guy but it was on a Buss bar with 6 or 7 similar fuses. 50 amp.
Rusty
__________________
2015 Black F-350 Platinum Diesel Dually Crew Cab
2019 Riverstone Legacy 38MB (Full Paint/All Options)
2015 Voltage 3990 (Full Paint, All Options) Sold 6/18
2005 Harley Ultra Classic w/too many miles
lcv800 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.



All times are GMT. The time now is 04:45 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.