New to the Forum - Dutchmen Owners

Go Back   Dutchmen Owners > Dutchmen RV Owner's Community Forums > New Member Introductions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 08-06-2014, 02:27 AM   #1
New Member
 
Join Date: Aug 2014
Location: Ft. Thomas
Posts: 8
Kentucky
New to the Forum

Hi all. Looking forward to the discussion. First time on the forum. On our third TT and second Kodiak. Currently pulling a 2014 300BHLS with an '04 Dodge Durango. Just from that, some of you might think I'm nuts--which I'm not denying--but I love my tow vehicle. I especially like the Hemi and the air lift system I added after the kids out grew the first Kodiak--a '11 284BHLS. My wife and I have been camping for as long as we've been married, and before that with our own parents as kids.
__________________

On-my-second-Kodiak is offline   Reply With Quote
Old 08-06-2014, 04:45 AM   #2
Senior Member
 
Adair1965's Avatar
 
Join Date: Nov 2013
Location: Barrie
Posts: 252
Ontario
Welcome to the forum, and no, I don't think your nuts, your just passionate about a Hemi engine.
__________________

__________________
I see dead people (really, I do!)
2014 Kodiak 291 RESL
2017 Ford F150 Lariet w/5 litre V8 and tow kit
Adair1965 is offline   Reply With Quote
Old 08-06-2014, 04:50 PM   #3
Senior Member
 
hddecker's Avatar
 
Join Date: Jul 2013
Location: kamloops
Posts: 2,152
British Columbia
Welcome to the forum. I have loved the Hemi since the day when I had a 56-57? Desoto. I wish I would have had the option of the 6.4l when I bought my Ram.
hddecker is offline   Reply With Quote
Old 08-06-2014, 07:17 PM   #4
Senior Member
 
DesertRat's Avatar
 
Join Date: Mar 2014
Location: Desert Hot Springs
Posts: 1,760
California
Welcome, like you my kids grew up in RV's like me & my wife did growing up also.
__________________
Mike
2002 42' Monaco Signature Triple Crown tow 2014 F-150
2014 Voltage V3605 Sold 5/3/17
2012 F-350 6.7l CC 4X4, Sold 10/10/17
DesertRat is offline   Reply With Quote
Old 08-09-2014, 12:42 AM   #5
Senior Member
 
lgarcia's Avatar
 
Join Date: Jun 2012
Location: West Virginia
Posts: 140
Welcome from another Hemi owner.
__________________
Laura, Rodney, and Elfie the Schnoodle
2012 Dutchmen 814RB; 2011 Dodge 1500 Hemi
lgarcia is offline   Reply With Quote
Old 08-11-2014, 03:07 AM   #6
New Member
 
Join Date: Aug 2014
Location: Ft. Thomas
Posts: 8
Kentucky
Thanks. How's the Hemi pull in WV. We took a trip to Beechfork. In Wayne County not long after we bought our first Kodiak. Beautiful state park. Crazy approach roads. Thought I saw the back of my own camper a few times on the tight turns.
On-my-second-Kodiak is offline   Reply With Quote
Old 08-13-2014, 09:35 PM   #7
Senior Member
 
prm99v6's Avatar
 
Join Date: Aug 2013
Location: Middletown
Posts: 192
Delaware
Welcome!
__________________

2014 Aerolite 282DBHS

myaeroliterv.com
prm99v6 is offline   Reply With Quote
Old 08-15-2014, 03:36 AM   #8
Senior Member
 
knesdad's Avatar
 
Join Date: Dec 2011
Location: Badger State
Posts: 431
Wisconsin
Howdy!
__________________
Forum Moderator

Dave & Sue
Kiley & Emily
Izzie (Beagle/Bichon/Mini Poodle)
2012 Ford F150 XLT EB SS CRW 6.5 Max Tow
'12 Dutchmen Kodiak 284BHSL
knesdad is offline   Reply With Quote
Old 08-15-2014, 07:27 AM   #9
New Member
 
Join Date: Aug 2014
Location: Villa Rica
Posts: 3
Georgia
We just bought a 2015 Aspen Trail 2390 RKS and everything worked PERFECT at the dealer. When it was hooked up to hubbys truck after the battery had been disconnected. ( we had to go buy our own) the LED lights were on still. We had to turn them off because supposedly they were running off the truck battery. Well we get home and plug it up to the house and now the AC will not come on, the LED lights will not come on and the fridge will not come on even if on Propane. I know the battery has to make the converter run the AC and the Fridge but when we unhooked the battery there was NOTHING lighting up. inside or out. Also when I hit my slide button that says slide-out in the darn thing goes out and vice versus. It was all fine at the dealer and then get home 20 min later and boom Nothing. Not even LED lights will work with the truck running. I am in tears! Someone said we just did not have enough juice coming from the extension cord to the camper but that does not explain the LED lights not working off the truck battery. Not a happy camper right now. We have owned it all of 6 hours! Any suggestions?
TRSGayle is offline   Reply With Quote
Old 08-15-2014, 11:15 AM   #10
Senior Member
 
sawpilot's Avatar
 
Join Date: Apr 2013
Location: Anacortes
Posts: 229
Washington
It's sounds like the battery switch was turned off before you left the dealer. There should be a master battery switch and it should be on.
__________________

__________________
Jeff
"All fisherman are liars, except you and me, and I'm beginning to wonder about you.
sawpilot is offline   Reply With Quote
Reply

Tags
durango, kodiak, trailer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Dutchmen RV or any of its affiliates. This is an independent, unofficial site.



All times are GMT. The time now is 06:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Copyright 2012 Social Knowledge, LLC All Rights Reserved.